Stuck on testing service account

Have a question about SnaPatch Patch Management software. Post it here, and we will help.
fstewart
Posts: 1
Joined: Wed Feb 24, 2016 6:26 pm

Stuck on testing service account

Postby fstewart » Thu Feb 25, 2016 7:47 am

Hi, I have installed SnaPatch as a trial and when I get to the setup wizard it fails when it tries to test the service account. It looks like it's failing to run WMI query but not sure why.

Also, when I run SnaPatch it tells me I don't admin rights, even though I'm an admin on the machine.

Jim
Posts: 2
Joined: Mon Feb 15, 2016 3:19 pm

Re: Stuck on testing service account

Postby Jim » Thu Feb 25, 2016 8:33 am

Hi fstewart, at the first phase of the setup, SnaPatch wants to make sure that it can read a particular namespace (root\cimv2) and recall the list of patches.

Have you tried connecting to different remote servers?

Another test you could try is running the below powershell command to ensure it can actually recall a result:
Get-WmiObject -Class Win32_QuickFixEngineering -ComputerName <RemoteServerName> -Credential <ServiceAccountName> -Namespace "ROOT\CIMV2" | Select-Object HotFixID

It should return a list of hotfixes on the remote server.

With regards to running SnaPatch as a domain account, it will require local admin access and to be launched as an administrator (right-click "Launch as administrator").

Please let us know if you have any further issues, we will be happy to help.


Return to “Questions”

Who is online

Users browsing this forum: No registered users and 0 guests